Restoration Manager is currently experiencing issues with Email Correspondence
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 23:43 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 03, 2021 - 18:32 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 03, 2021 - 17:20 MDT
This incident affected: Restoration Manager, Inspection Manager, and Punchlist Manager.