Issues with Images
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted 6 days ago. Sep 11, 2019 - 11:57 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 days ago. Sep 11, 2019 - 11:15 MDT
Investigating
We are currently investigating this issue.
Posted 6 days ago. Sep 11, 2019 - 10:46 MDT
This incident affected: Claims Backend Services (Images / Photos).