Intermittent access issues with Xactimate online
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted Jun 07, 2021 - 16:28 MDT
Investigating
We are currently investigating this issue.
Posted Jun 07, 2021 - 09:56 MDT
This incident affected: Xactimate / XactContents online (Main Site).