The incident has been resolved, and Xactimate Online is operating normally. Thank you for your patience while we worked to resolve this issue.
Posted Jul 24, 2026 - 15:21 MDT
Monitoring
Our technical teams have rolled back the recent change identified as the potential cause of the issue. Services have been restored, and we are actively monitoring the application's stability to ensure normal operation.
If you continue to experience issues accessing the application, please clear your browser cache and cookies and try again.
Thank you for your patience and understanding while we worked to resolve this issue.
Posted Jul 24, 2026 - 15:09 MDT
Investigating
Our technical teams are actively investigating the issue to identify the root cause. We appreciate your patience and understanding as we work to resolve it as quickly as possible.
Posted Jul 24, 2026 - 14:55 MDT
This incident affected: Xactimate / XactContents online (Main Site).