Resolved: We encountered an issue with access to the Time and Material forms website

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 15:52 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2026 - 15:43 MST

Investigating

We are currently investigating this issue.
Posted Jan 06, 2026 - 14:54 MST
This incident affected: Xactimate / XactContents online (Main Site).