Resolved: Some Xactimate customers were unable to access Xactimate online and desktop(X1)
Incident Report for Xactware
Resolved
The Xactimate online and desktop issue has been resolved, and normal operations have been reinstated.
Posted Mar 28, 2024 - 16:21 MDT
Monitoring
The IT team and AWS vendor are investigating the cause, while we monitor the system's stability closely.
Posted Mar 28, 2024 - 16:07 MDT
Update
The Xactimate online and desktop (X1) application's database recently experienced high load but has since returned to normal.
Posted Mar 28, 2024 - 15:55 MDT
Investigating
Our Verisk IT team and AWS vendor are actively investigating the Xactimate online and desktop(X1) disruption and appreciate your patience as we work to identify the root cause.
Posted Mar 28, 2024 - 15:43 MDT
This incident affected: Xactimate / XactContents online (Main Site).