Technical Support Phone Outage
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 15:46 MDT
Investigating
We are currently experiencing issues with our phone systems. For technical support please use live chat at
https://veriskpropertyestimatingsolutions.my.site.com/s/
Posted Mar 19, 2024 - 15:11 MDT