Identified: We are currently experiencing an issue displaying XactAnalysis claims invoice data in XactInsights

Update

Additional Checks and Validations are still in progress. This will extend our ETA an additional three hours from this point.
Posted Feb 03, 2026 - 16:18 MST

Identified

Our technical teams are actively validating the fix. We will provide further updates as more information becomes available. Thank you for your patience.
Posted Feb 03, 2026 - 15:17 MST

Update

We've identified the cause of the XactInsights disruption and are actively working on implementing a solution. The estimated time to fix the issue is around 4 hours.
Posted Feb 03, 2026 - 14:12 MST

Investigating

Our technical teams are actively working on identifying the cause of the issue.
Posted Feb 03, 2026 - 13:00 MST
This incident affects: XactInsights.