Resolved: We experienced slowness when opening projects in Xactimate Online.

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 10:24 MDT

Monitoring

Our technical teams have rolled back the product release that was deployed yesterday as a temporary mitigation and recycled the impacted application servers to resolve the issue. We are actively monitoring the application's stability to ensure normal service has been restored.
Posted Jul 08, 2026 - 09:48 MDT

Investigating

Our team is currently investigating the issue affecting Xactimate Online. Rest assured, we're working diligently to restore normal service.
Posted Jul 08, 2026 - 09:03 MDT
This incident affected: Xactimate / XactContents online (Main Site).