We currently experiencing slowness issues within Xactimate Desktop (X1)
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 20:36 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2021 - 20:15 MDT
Investigating
We are currently investigating this issue.
Posted Apr 07, 2021 - 19:51 MDT
This incident affected: Xactimate / XactContents online (Main Site).