Resolved: We experienced issues with the standalone version of XactContents Online.

Resolved

Our technical teams have reverted the recent application release as part of immediate mitigation efforts to stabilize the system and resolve the issue.
Posted Apr 22, 2026 - 16:38 MDT

Investigating

Our technical teams are actively investigating the issue to identify the root cause and implement a resolution as quickly as possible. We appreciate your patience and understanding as we work to resolve this.
Posted Apr 22, 2026 - 16:16 MDT
This incident affected: Xactimate / XactContents online (Main Site).