Resolved: We experienced issues logging into ContentsTrack

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 16:54 MDT

Monitoring

Our web application firewall vendor has implemented a fix for Contentstrack.com to resolve the issue. We are currently monitoring stability.
Posted Apr 16, 2026 - 16:36 MDT

Update

Our technical teams are actively working to identify and implement a solution to resolve the issue as quickly as possible. Thank you for your patience.
Posted Apr 16, 2026 - 15:51 MDT

Update

Cause identified: Our team is in the process of resolving the ContentsTrack Login issue to restore normal service.
Posted Apr 16, 2026 - 15:04 MDT

Investigating

We are currently investigating this issue.
Posted Apr 16, 2026 - 13:05 MDT
This incident affected: ContentsTrack.