Resolved: We experienced issues with uploading assignments to XactAnalysis

Resolved

This incident has been resolved, and services are operating normally. We appreciate your patience and understanding while our team worked on the issue.
Posted May 13, 2026 - 09:45 MDT

Monitoring

We have implemented a fix for the issue and are currently monitoring.
Posted May 13, 2026 - 09:19 MDT

Investigating

We are currently investigating this issue.
Posted May 13, 2026 - 08:37 MDT
This incident affected: Xactimate / XactContents online (Main Site).