Xactimate Online - Intermittent Slowness Issue
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted 4 months ago. May 09, 2019 - 10:27 MDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. May 09, 2019 - 09:08 MDT
This incident affected: Xactimate / XactContents online (Main Site).