Xactimate Online and XactContents Online Release - May 21
Scheduled for May 21, 22:00 MDT  -  May 22, 00:00 MDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 09, 2024 - 07:21 MDT
Scheduled
The release is planned for Xactimate services supporting Xactimate Online and XactContents Online on Tuesday, May 21st between 10 PM and 12 AM Mountain Time. During this time Xactimate online will be unavailable.

Please contact Verisk Support Services if you have any questions or concerns.

Thank you,

Verisk Support Services
https://eservice.xactware.com / 1-800-710-9228
Posted Apr 09, 2024 - 07:19 MDT
This scheduled maintenance affects: Xactimate / XactContents online (Main Site).