Xactimate Online, XactContents Online and ContentsTrack - Partial Outage
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 17, 2019 - 10:29 MST
Investigating
We are currently investigating this issue.
Posted 7 months ago. Feb 17, 2019 - 08:37 MST
This incident affected: Claims Backend Services (Images / Photos), Xactimate / XactContents online (Main Site), and ContentsTrack.