Monitoring - We are experienced an issue with XactInsights redirecting to an incorrect page.

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 08:18 MDT

Monitoring

The infrastructure change for the authentication services supporting XactAnalysis Insights was rolled back to resolve the issue. We are currently monitoring the application for stability.
Posted Mar 28, 2025 - 07:32 MDT

Investigating

We're actively investigating the XactInsights disruption and appreciate your patience as we work to identify the root cause.
Posted Mar 28, 2025 - 06:47 MDT
This incident affected: XactAnalysis (Insights).