Resolved: We experienced issues with our 800 numbers for our Billing and Sales departments.

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 10:32 MDT

Investigating

We are currently experiencing issues with our 800 numbers for our Billing and Sales departments. They can still be contacted by calling our main line at (800) 932-9228, and selecting the option for the desired department.
Posted Mar 24, 2025 - 09:48 MDT
This incident affected: eService Center.