Resolved: XactAnalysis experienced slowness

Resolved

The XactAnalysis slowness issue has been resolved, and normal operations have been reinstated.
Posted Sep 14, 2023 - 08:43 MDT

Update

We are continuing to monitor for any further issues.
Posted Sep 14, 2023 - 08:35 MDT

Monitoring

Our team is actively monitoring system stability following the rollback of the impacted service to the previous version in XactAnalysis to ensure sustained service reliability
Posted Sep 14, 2023 - 08:29 MDT

Investigating

Our technical team is currently scaling up additional application servers. Investigation is underway for the XactAnalysis service issue. We'll update you as soon as we have more information.
Posted Sep 14, 2023 - 07:37 MDT
This incident affected: XactAnalysis (Main Site).