Resolved: We are experiencing issues loading data in XactInsights

Resolved

This incident has been resolved.
Posted Dec 29, 2025 - 11:09 MST

Monitoring

The analytics platform vendor has pinpointed the impacts component responsible for the connection issues and has recycled it to address the problem. Our technical teams continue to monitor system stability.
Posted Dec 29, 2025 - 10:35 MST

Update

Our Technical Team suspects the issue may be related to the third-party analytics platform that supports XactInsights. Our team is actively working with the third-party vendor to investigate and resolve the issue as quickly as possible.
Thank you for your patience and understanding.
Posted Dec 29, 2025 - 09:44 MST

Investigating

We are currently investigating this issue.
Posted Dec 29, 2025 - 08:50 MST
This incident affected: XactInsights.