Resolved: We experienced intermittent issues accessing XactAnalysis

Resolved

Service has been fully restored for XactAnalysis. We appreciate your patience during this time.
Posted Mar 26, 2026 - 23:55 MDT

Update

A fix has been implemented and we are closely monitoring the system's stability.
Posted Mar 26, 2026 - 23:45 MDT

Investigating

Our team is currently investigating the issue affecting XactAnalysis. Rest assured, we're working diligently to restore normal service.
Posted Mar 26, 2026 - 23:08 MDT
This incident affected: XactAnalysis (Main Site).