Resolved: We experienced connectivity issues in Xactimate desktop(X1) and Xactimate online.

Resolved

Our technical team has identified the underlying cause of the high database connection issue and implemented a fix. The applications are now working as expected. Thank you for your patience and understanding.
Posted Aug 28, 2026 - 11:56 MDT

Investigating

Our technical teams are actively investigating and working to identify the root cause of the connectivity issues affecting Xactimate desktop(X1) and Xactimate online. We will provide further updates as soon as additional information becomes available.
Posted Aug 28, 2026 - 10:45 MDT
This incident affected: Xactimate / XactContents online (Main Site).