Resolved: Xactware.com experienced issues with Multi-Factor Authentication emails.

Resolved

Services has been fully restored for Xactware.com. We appreciate your patience during this time.
Posted Nov 11, 2025 - 03:40 MST

Investigating

We're actively investigating the disruption caused by Xactware.com and appreciate your patience as we work to identify the root cause.
Posted Nov 11, 2025 - 03:22 MST
This incident affected: Xactware.com.