Unable to access Punchlist Manager and Restoration Manager
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 15:32 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2023 - 14:35 MDT
Investigating
We are currently investigating this issue.
Posted Mar 23, 2023 - 13:47 MDT
This incident affected: Restoration Manager and Punchlist Manager.