Xactimate Online and XactContents Intermittent Issue
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 04, 2019 - 10:10 MST
Investigating
We are currently investigating this issue.
Posted 7 months ago. Feb 04, 2019 - 08:49 MST
This incident affected: Xactimate / XactContents online (Main Site).