Resolved: Few customers experienced connection issues in Xactimate
Resolved
The issue has been resolved, with only a limited number of customers affected.
Posted Nov 07, 2024 - 09:26 MST
Investigating
We're actively investigating the Xactimate disruption and appreciate your patience as we work to identify the root cause.
Posted Nov 07, 2024 - 09:02 MST
This incident affected: Xactimate / XactContents online (Main Site).