Xactimate Online and XactContents Online Partial Outage
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 11, 2019 - 15:30 MST
Investigating
We are currently investigating this issue.
Posted 8 months ago. Jan 11, 2019 - 14:54 MST
This incident affected: Xactimate / XactContents online (Main Site).