Resolved: We experienced intermittent issues creating and managing Xactware ID

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 08:58 MDT

Monitoring

We have implemented a fix for the issue.
Posted Jun 24, 2026 - 08:46 MDT

Identified

We have identified the root cause and are working towards a resolution. We appreciate your patience while we restore service.
Posted Jun 24, 2026 - 08:25 MDT

Investigating

We are currently investigating this issue.
Posted Jun 24, 2026 - 07:59 MDT
This incident affected: Xactimate / XactContents online (Main Site).