eService center chat is unavailable

Resolved

This incident has been resolved.
Posted May 21, 2023 - 21:42 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2023 - 21:26 MDT

Investigating

eService Center chats are unavailable and customers can call us for Technical support at 800-710-9228
Posted May 21, 2023 - 19:40 MDT
This incident affected: eService Center.