We are currently experiencing Issues logging into and operating Xactimate
Incident Report for Xactware
Resolved
This incident has been resolved.
Posted Mar 29, 2023 - 13:14 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 29, 2023 - 12:38 MDT
Update
The login issues with the Xactimate applications have been resolved. Currently, the Verisk IT teams are troubleshooting to the slowness issues in the applications.
Posted Mar 29, 2023 - 11:30 MDT
Investigating
We are currently investigating this issue.
Posted Mar 29, 2023 - 08:11 MDT
This incident affected: Xactimate / XactContents online (Main Site).